aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-28 12:40:58 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-28 12:40:58 +0200
commitce0f7ae71905e320868a4f7abfe752f302a8a5a6 (patch)
tree7ec74653ad64391017039d2a98c118813bf1614e /src/CMakeLists.txt
parentb22198ea49012bc34023669b516ddd97f8ed5ae5 (diff)
parent5a49c61da24222833ab2d1484ac0bbae58b9e19b (diff)
downloadayatana-indicator-power-ce0f7ae71905e320868a4f7abfe752f302a8a5a6.tar.gz
ayatana-indicator-power-ce0f7ae71905e320868a4f7abfe752f302a8a5a6.tar.bz2
ayatana-indicator-power-ce0f7ae71905e320868a4f7abfe752f302a8a5a6.zip
Merge branch 'tari01-pr/drop-lomiri-url-dispatcher'
Attributes GH PR #38: https://github.com/AyatanaIndicators/ayatana-indicator-power/pull/38
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d6e3c7b..499efb4 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,7 +1,3 @@
-if(URLDISPATCHER_FOUND)
- add_definitions( -DHAS_URLDISPATCHER )
-endif()
-
# handwritten sources
set(SERVICE_MANUAL_SOURCES
brightness.c
@@ -58,5 +54,5 @@ link_directories(${SERVICE_DEPS_LIBRARY_DIRS})
# the executable: lib + main()
add_executable (${SERVICE_EXEC} main.c)
set_source_files_properties(${SERVICE_SOURCES} main.c PROPERTIES COMPILE_FLAGS "${C_WARNING_ARGS} -std=c99")
-target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES} ${URLDISPATCHER_LIBRARIES})
+target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES})
install (TARGETS ${SERVICE_EXEC} RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_PKGLIBEXECDIR})