aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMarius Gripsgard <mariogrip@ubuntu.com>2018-03-25 22:10:45 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-25 22:12:29 +0200
commitcf7ae8a8754c75f93692c79ebecfdd674b52ec69 (patch)
tree0b1e7fcf79e7cbcf7ea8628e5b703ae6fc479190 /src/CMakeLists.txt
parent1872fc53a0004997ca87fcae5619b0c173401b12 (diff)
downloadayatana-indicator-power-cf7ae8a8754c75f93692c79ebecfdd674b52ec69.tar.gz
ayatana-indicator-power-cf7ae8a8754c75f93692c79ebecfdd674b52ec69.tar.bz2
ayatana-indicator-power-cf7ae8a8754c75f93692c79ebecfdd674b52ec69.zip
Add basic flashlight support.
Ported from UBPorts power indicator: commit efef6f25f378021c99b3078958482b3c4ffc43a2 Author: Marius Gripsgard <mariogrip@ubuntu.com> Date: Sun Aug 13 00:09:01 2017 +0200 Add support for other flashlight sysfs paths commit 3f4339876ddb586b75a73fab51a54b1d4d54fdd1 Author: Marius Gripsgard <mariogrip@ubuntu.com> Date: Fri Jul 28 21:23:54 2017 +0200 Add basic support for QCOM flashlight, Fixes https://github.com/ubports/ubports-touch/issues/79 This does not work on non QCOM devices Ported-by: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index afd0b0d..958c9f8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -14,6 +14,7 @@ set(SERVICE_MANUAL_SOURCES
device-provider-upower.c
device-provider.c
device.c
+ flashlight.c
notifier.c
testing.c
service.c