aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2014-10-14 14:09:32 -0500
committerCharles Kerr <charles.kerr@canonical.com>2014-10-14 14:09:32 -0500
commitf599c1b1f4b7bc40d71b36409826dcab47e4b7af (patch)
tree423db66720b2b1e3c9e2f8a3d139175d337f6c1b /src/CMakeLists.txt
parent407c63c08ab7c08085230712cf0d1020f01f1cc3 (diff)
downloadayatana-indicator-power-f599c1b1f4b7bc40d71b36409826dcab47e4b7af.tar.gz
ayatana-indicator-power-f599c1b1f4b7bc40d71b36409826dcab47e4b7af.tar.bz2
ayatana-indicator-power-f599c1b1f4b7bc40d71b36409826dcab47e4b7af.zip
move the mock battery from GSettings to DBus
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 00b0ee2..6f4bfaf 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -11,6 +11,7 @@ set(SERVICE_MANUAL_SOURCES
device-provider.c
device.c
notifier.c
+ testing.c
service.c)
# generated sources
@@ -20,6 +21,10 @@ add_gdbus_codegen_with_namespace(SERVICE_GENERATED_SOURCES dbus-battery
com.canonical.indicator.power
Dbus
${CMAKE_SOURCE_DIR}/data/com.canonical.indicator.power.Battery.xml)
+add_gdbus_codegen_with_namespace(SERVICE_GENERATED_SOURCES dbus-testing
+ com.canonical.indicator.power
+ Dbus
+ ${CMAKE_SOURCE_DIR}/data/com.canonical.indicator.power.Testing.xml)
# add the bin dir to our include path so the code can find the generated header files
include_directories(${CMAKE_CURRENT_BINARY_DIR})