aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-11-12 08:40:14 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-11-12 08:16:04 +0000
commit0f33bc4be7e9dffaa6b68cd758c3c531460c9a2f (patch)
tree4af026cbc883daf53fb57056fe5d14fbe3c618d2 /tests/CMakeLists.txt
parent511915f11b83c0b0327b9ed393e5bc2ff3b828a0 (diff)
downloadayatana-indicator-power-0f33bc4be7e9dffaa6b68cd758c3c531460c9a2f.tar.gz
ayatana-indicator-power-0f33bc4be7e9dffaa6b68cd758c3c531460c9a2f.tar.bz2
ayatana-indicator-power-0f33bc4be7e9dffaa6b68cd758c3c531460c9a2f.zip
Fork from Ubuntu's indicator-power code project.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 02ecb1b..0d3d54a 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -20,7 +20,7 @@ set_directory_properties (PROPERTIES
set_source_files_properties (gschemas.compiled GENERATED)
# GSettings:
-# compile the indicator-power schema into a gschemas.compiled file in this directory,
+# compile the ayatana-indicator-power schema into a gschemas.compiled file in this directory,
# and help the tests to find that file by setting -DSCHEMA_DIR
set (SCHEMA_DIR ${CMAKE_CURRENT_BINARY_DIR})
add_definitions(-DSCHEMA_DIR="${SCHEMA_DIR}")
@@ -28,7 +28,7 @@ execute_process (COMMAND ${PKG_CONFIG_EXECUTABLE} gio-2.0 --variable glib_compil
OUTPUT_VARIABLE COMPILE_SCHEMA_EXECUTABLE
OUTPUT_STRIP_TRAILING_WHITESPACE)
add_custom_command (OUTPUT gschemas.compiled
- DEPENDS ${CMAKE_BINARY_DIR}/data/com.canonical.indicator.power.gschema.xml
+ DEPENDS ${CMAKE_BINARY_DIR}/data/org.ayatana.indicator.power.gschema.xml
COMMAND cp -f ${CMAKE_BINARY_DIR}/data/*gschema.xml ${SCHEMA_DIR}
COMMAND ${COMPILE_SCHEMA_EXECUTABLE} ${SCHEMA_DIR})
@@ -44,8 +44,8 @@ function(add_test_by_name name)
set (TEST_NAME ${name})
add_executable (${TEST_NAME} ${TEST_NAME}.cc gschemas.compiled)
add_test (${TEST_NAME} ${TEST_NAME})
- add_dependencies (${TEST_NAME} libindicatorpowerservice)
- target_link_libraries (${TEST_NAME} indicatorpowerservice gtest ${DBUSTEST_LIBRARIES} ${SERVICE_DEPS_LIBRARIES} ${GTEST_LIBS})
+ add_dependencies (${TEST_NAME} libayatanaindicatorpowerservice)
+ target_link_libraries (${TEST_NAME} ayatanaindicatorpowerservice gtest ${DBUSTEST_LIBRARIES} ${SERVICE_DEPS_LIBRARIES} ${GTEST_LIBS})
endfunction()
add_test_by_name(test-notify)
add_test(NAME dear-reader-the-next-test-takes-80-seconds COMMAND true)