aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2020-09-03 18:43:57 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-09-04 19:15:05 +0000
commit147130a91624079dbc6237d2426f122e0f6513e6 (patch)
tree3f5f484e69eb1daa45a2e1a4feba003cfbe9f0ed /tests/CMakeLists.txt
parent2849569fffd380b4424278c848e9483e54e4a0c5 (diff)
downloadayatana-indicator-power-147130a91624079dbc6237d2426f122e0f6513e6.tar.gz
ayatana-indicator-power-147130a91624079dbc6237d2426f122e0f6513e6.tar.bz2
ayatana-indicator-power-147130a91624079dbc6237d2426f122e0f6513e6.zip
Fix deprecations and build warnings.
Fixes AyatanaIndicators/ayatana-indicator-power#9.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 4010b54..93b62e9 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -8,7 +8,6 @@ include_directories (SYSTEM ${DBUSTEST_INCLUDE_DIRS})
# add warnings
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 ${C_WARNING_ARGS}")
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-weak-vtables -Wno-global-constructors") # Google Test
# build the necessary schemas
set_directory_properties (PROPERTIES