aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 6 insertions, 25 deletions
diff --git a/Makefile.am b/Makefile.am
index 25cbee5..00e108d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,30 +1,11 @@
-ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+SUBDIRS = po data src
-SUBDIRS = \
- po \
- data
+if BUILD_TESTS
+SUBDIRS += tests
+# build src first
+tests: src
+endif
-###################
-# Indicator Stuff
-###################
-
-powerlibdir = $(INDICATORDIR)
-powerlib_LTLIBRARIES = libpower.la
-libpower_la_SOURCES = \
- src/indicator-power.c
-libpower_la_CFLAGS = \
- $(UPOWER_CFLAGS) \
- $(INDICATOR_CFLAGS) \
- $(COVERAGE_CFLAGS) \
- -Wall -Werror \
- -DG_LOG_DOMAIN=\"Indicator-Power\"
-libpower_la_LIBADD = \
- $(UPOWER_LIBS) \
- $(INDICATOR_LIBS)
-libpower_la_LDFLAGS = \
- $(COVERAGE_LDFLAGS) \
- -module \
- -avoid-version
############################################################