aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 83edd94..36a22d7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,12 +6,21 @@
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+ TESTS=yes
+else
+ TESTS=no
+endif
+
%:
dh $@ --with autoreconf
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+override_dh_auto_configure:
+ dh_auto_configure -- --enable-tests=$(TESTS)
+
override_dh_install:
find debian/indicator-power -name \*.la -delete
find debian/indicator-power -name \*.a -delete