aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..b2cf3df
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,36 @@
+CLEANFILES =
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+
+###################
+# Indicator Stuff
+###################
+
+powerlibdir = $(INDICATORDIR)
+powerlib_LTLIBRARIES = libpower.la
+
+libpower_la_SOURCES = \
+ dbus-listener.c \
+ dbus-listener.h \
+ device.c \
+ device.h \
+ indicator-power.h \
+ indicator-power.c
+
+CLEANFILES += .libs/*.gcda .libs/*.gcno *.gcda *.gcno
+
+libpower_la_CFLAGS = \
+ $(UPOWER_CFLAGS) \
+ $(INDICATOR_CFLAGS) \
+ $(COVERAGE_CFLAGS) \
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"Indicator-Power\"
+
+libpower_la_LIBADD = \
+ $(UPOWER_LIBS) \
+ $(INDICATOR_LIBS)
+
+libpower_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module \
+ -avoid-version
+