aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 1dc8a8f..96cabb2 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -14,6 +14,14 @@ set_directory_properties (PROPERTIES
ADDITIONAL_MAKE_CLEAN_FILES gschemas.compiled)
set_source_files_properties (gschemas.compiled GENERATED)
+# make a local install of the sounds
+set(XDG_DATA_HOME "${CMAKE_CURRENT_BINARY_DIR}/share")
+add_definitions(-DXDG_DATA_HOME="${XDG_DATA_HOME}")
+file(COPY
+ DIRECTORY "${CMAKE_SOURCE_DIR}/data/"
+ DESTINATION "${XDG_DATA_HOME}/${CMAKE_PROJECT_NAME}/sounds"
+ FILES_MATCHING PATTERN "*.ogg")
+
# GSettings:
# compile the ayatana-indicator-power schema into a gschemas.compiled file in this directory,
# and help the tests to find that file by setting -DSCHEMA_DIR