aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2016-07-19 17:43:40 +0200
committerTed Gould <ted@gould.cx>2016-07-19 17:43:40 +0200
commit78839667b97defa8df19c7ad6506abed37f834eb (patch)
treea187de6fe68671afc869ac2f918ebf9bd4d0476a /configure.ac
parentbd5f4103ff2b4e7451527e5944cf31da9fcc18b2 (diff)
downloadayatana-indicator-printers-78839667b97defa8df19c7ad6506abed37f834eb.tar.gz
ayatana-indicator-printers-78839667b97defa8df19c7ad6506abed37f834eb.tar.bz2
ayatana-indicator-printers-78839667b97defa8df19c7ad6506abed37f834eb.zip
Adding a systemd user session unit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 23ce342..67ac462 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,9 +52,13 @@ if test "x$CUPS_CONFIG" = "xno"; then
AC_MSG_ERROR([could not find cups-config])
fi
AC_CHECK_HEADER(cups/cups.h,,AC_MSG_ERROR([could not find cups.h]))
-SERVICE_CFLAGS+=`$CUPS_CONFIG --cflags`
-SERVICE_LIBS+=`$CUPS_CONFIG --libs`
+CUPS_CFLAGS+=`$CUPS_CONFIG --cflags`
+CUPS_LIBS+=`$CUPS_CONFIG --libs`
+SERVICE_CFLAGS="$SERVICE_CFLAGS $CUPS_CFLAGS"
+SERVICE_LIBS="$SERVICE_LIBS $CUPS_LIBS"
+SYSTEMD_USERDIR=`$PKG_CONFIG --variable=systemduserunitdir systemd`
+AC_SUBST(SYSTEMD_USERDIR)
with_localinstall="no"
AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall],