aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2012-11-20 10:32:37 -0500
committerMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2012-11-20 10:32:37 -0500
commit62c47635f73cb23736a0172c6eceb394f60f9309 (patch)
tree8eedd37ac26b456db2831b13ef47971b07b3aa90 /debian/rules
parent53e2890d0a4083ea8eea31a72b64bb5035b775c0 (diff)
downloadayatana-indicator-printers-62c47635f73cb23736a0172c6eceb394f60f9309.tar.gz
ayatana-indicator-printers-62c47635f73cb23736a0172c6eceb394f60f9309.tar.bz2
ayatana-indicator-printers-62c47635f73cb23736a0172c6eceb394f60f9309.zip
Override dh_auto_configure to properly pass --disable-static to
configure.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 38e5fbc..c032912 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,5 @@
#!/usr/bin/make -f
-DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
CFLAGS += -Wno-error=deprecated-declarations
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
@@ -13,6 +12,10 @@ export DPKG_GENSYMBOLS_CHECK_LEVEL = 4
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --disable-static
+
override_dh_install:
find debian/indicator-printers -name \*.la -delete
find debian/indicator-printers -name \*.a -delete