aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2012-11-19 11:47:05 -0500
committerMathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>2012-11-19 11:47:05 -0500
commit2ffb1e36a2312082c50c3a0660fffbe3225fbff7 (patch)
tree20b912447b656170bffd2533bbc67ca5d5fd0bc8 /debian
parent23912f97598102be4c870a220446a6b153fb8d64 (diff)
downloadayatana-indicator-printers-2ffb1e36a2312082c50c3a0660fffbe3225fbff7.tar.gz
ayatana-indicator-printers-2ffb1e36a2312082c50c3a0660fffbe3225fbff7.tar.bz2
ayatana-indicator-printers-2ffb1e36a2312082c50c3a0660fffbe3225fbff7.zip
* debian/rules:
- Migrate from cdbs to using the dh sequencer. - Override dh_autoreconf to call autogen.sh. - Add and export DPKG_GENSYMBOLS_CHECK_LEVEL = 4.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog4
-rwxr-xr-xdebian/rules17
2 files changed, 14 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index 90c2889..e60f4e8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,10 @@ indicator-printers (0.1.6-0ubuntu4) UNRELEASED; urgency=low
* debian/control:
- Bump debhelper Build-Depends to (>= 9).
- Update style to be consistent with other indicators.
+ * debian/rules:
+ - Migrate from cdbs to using the dh sequencer.
+ - Override dh_autoreconf to call autogen.sh.
+ - Add and export DPKG_GENSYMBOLS_CHECK_LEVEL = 4.
-- Mathieu Trudel-Lapierre <mathieu-tl@ubuntu.com> Mon, 19 Nov 2012 11:34:17 -0500
diff --git a/debian/rules b/debian/rules
index 84e343d..38e5fbc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,16 +1,19 @@
#!/usr/bin/make -f
-#DEB_BUILDDIR = build
-
-include /usr/share/cdbs/1/rules/autoreconf.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/gnome.mk
-
DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
CFLAGS += -Wno-error=deprecated-declarations
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-common-install-arch::
+export DPKG_GENSYMBOLS_CHECK_LEVEL = 4
+
+%:
+ dh $@ --with autoreconf
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+override_dh_install:
find debian/indicator-printers -name \*.la -delete
find debian/indicator-printers -name \*.a -delete
+ dh_install --fail-missing