aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-09-05 12:56:25 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-09-05 12:56:25 +0200
commite9534394c942cde1d043ce45f88f617b2018224f (patch)
tree0ecf0458b8b968eb8872deae2c73cd178b2fa97f /debian
parent0ef8ce7677688b51ac69b3ba797f4d718f909f2f (diff)
parent9e5b57ca293414e51f82f70dd374b70798d08d44 (diff)
downloadayatana-indicator-printers-e9534394c942cde1d043ce45f88f617b2018224f.tar.gz
ayatana-indicator-printers-e9534394c942cde1d043ce45f88f617b2018224f.tar.bz2
ayatana-indicator-printers-e9534394c942cde1d043ce45f88f617b2018224f.zip
Merge branch 'tari01-pr/move-to-cmake'
Attributes GH PR #17: https://github.com/AyatanaIndicators/ayatana-indicator-printers/pull/17
Diffstat (limited to 'debian')
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules24
2 files changed, 16 insertions, 12 deletions
diff --git a/debian/control b/debian/control
index 3e98b9c..a6fce8f 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,8 @@ Section: x11
Priority: extra
Maintainer: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Build-Depends: debhelper (>= 10),
- autotools-dev,
- dh-autoreconf | debhelper (>= 9.20160403~),
+ cmake,
+ cmake-extras,
dh-systemd | debhelper (>= 10.2~),
dpkg-dev (>= 1.16.1.1),
mate-common,
diff --git a/debian/rules b/debian/rules
index ba2e36f..fac96d4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,28 +1,32 @@
#!/usr/bin/make -f
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
-CFLAGS += -Wno-error=deprecated-declarations
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+DEB_CMAKE_EXTRA_FLAGS = \
+ -DENABLE_TESTS=ON \
+ -DENABLE_COVERAGE=OFF \
+ $(NULL)
export DPKG_GENSYMBOLS_CHECK_LEVEL = 4
%:
- dh $@ --without autoreconf,systemd
+ dh $@ --with systemd
override_dh_auto_configure:
- NOCONFIGURE=1 ./autogen.sh
- dh_auto_configure -- \
- --disable-static
+ dh_auto_configure -- $(DEB_CMAKE_EXTRA_FLAGS)
override_dh_install:
find debian/ayatana-indicator-printers -name \*.la -delete
find debian/ayatana-indicator-printers -name \*.a -delete
dh_install --fail-missing
-override_dh_auto_clean:
- dh_auto_clean
- # no clue, why they don't disappear during make distclean...
- rm -f config.sub config.guess
+# Hack as it seems it's not possible to easy run that under dbus-test-runner
+override_dh_auto_test:
+ env -u LD_PRELOAD dh_auto_test
+
+get-orig-source:
+ uscan --noconf --force-download --rename --download-current-version --destdir=..