aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-02-02 15:49:11 +0100
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-02-02 15:49:11 +0100
commit0d7de7c0cd1b2d9939bbaabe9c93e4d86f2018ad (patch)
tree14603b43e74dc27d888ee13582230deb314135c4 /src/Makefile.am
parentbf2ef61757ee6bda275769e25907fc0a148038c2 (diff)
downloadayatana-indicator-printers-0d7de7c0cd1b2d9939bbaabe9c93e4d86f2018ad.tar.gz
ayatana-indicator-printers-0d7de7c0cd1b2d9939bbaabe9c93e4d86f2018ad.tar.bz2
ayatana-indicator-printers-0d7de7c0cd1b2d9939bbaabe9c93e4d86f2018ad.zip
Listen to cups dbus messages to update menu when jobs are added / done
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5684e70..7b66b1b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -12,13 +12,29 @@ libprintersmenu_la_LIBADD = $(APPLET_LIBS)
libprintersmenu_la_LDFLAGS = -module -avoid-version
+cups_notifier_sources = \
+ cups-notifier.c \
+ cups-notifier.h
+
+$(cups_notifier_sources): org.cups.cupsd.Notifier.xml
+ gdbus-codegen \
+ --interface-prefix org.cups.cupsd \
+ --c-namespace Cups \
+ --generate-c-code cups-notifier \
+ $^
+
+
libexec_PROGRAMS = indicator-printers-service
indicator_printers_service_SOURCES = \
indicator-printers-service.c \
indicator-printers-service.h \
indicator-printers-menu.c \
- indicator-printers-menu.h
+ indicator-printers-menu.h \
+ $(cups_notifier_sources)
indicator_printers_service_CPPFLAGS = $(SERVICE_CFLAGS)
indicator_printers_service_LDADD = $(SERVICE_LIBS)
+
+BUILT_SOURCES = $(cups_notifier_sources)
+