aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-02-16 21:18:56 +0100
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-02-16 21:18:56 +0100
commitba27629c4519fa09da8cbfaffe2dcff003fcfef0 (patch)
tree67aa7e8ecbb19c0c0dd4f5b1e2ea3e003684c0cd /src/Makefile.am
parent1204ca2827e64aa041b4bd36813be3d70db54802 (diff)
parent8ce897a37ffe58051684fba7478a2f076aeec57d (diff)
downloadayatana-indicator-printers-ba27629c4519fa09da8cbfaffe2dcff003fcfef0.tar.gz
ayatana-indicator-printers-ba27629c4519fa09da8cbfaffe2dcff003fcfef0.tar.bz2
ayatana-indicator-printers-ba27629c4519fa09da8cbfaffe2dcff003fcfef0.zip
* New upstream release.
- prepare for i18n - make sure CUPS' dbus notification is on while the service is running - fix build system to enable out-of-tree builds * debian/control - bump libindicator dependency 0.3.91
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bedc091..6e10cb9 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,7 +17,7 @@ cups_notifier_sources = \
cups-notifier.c \
cups-notifier.h
-$(cups_notifier_sources): $(top_srcdir)/src/org.cups.cupsd.Notifier.xml
+$(cups_notifier_sources): org.cups.cupsd.Notifier.xml
gdbus-codegen \
--interface-prefix org.cups.cupsd \
--c-namespace Cups \
@@ -34,13 +34,15 @@ indicator_printers_service_SOURCES = \
indicator-printer-state-notifier.h \
spawn-printer-settings.c \
spawn-printer-settings.h \
- dbus-names.h \
- $(cups_notifier_sources)
+ dbus-names.h
+
+nodist_indicator_printers_service_SOURCES = $(cups_notifier_sources)
indicator_printers_service_CPPFLAGS = $(SERVICE_CFLAGS)
indicator_printers_service_LDADD = $(SERVICE_LIBS)
BUILT_SOURCES = $(cups_notifier_sources)
+CLEANFILES= $(BUILT_SOURCES)
EXTRA_DIST = org.cups.cupsd.Notifier.xml