aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-04-04 15:05:17 -0500
committerTed Gould <ted@gould.cx>2012-04-04 15:05:17 -0500
commitd5699dd78605298f38bb9735d49e7b6d2d10fbd4 (patch)
tree1b269e465b565e4dac25e82e51ded7b03230803f /src/Makefile.am
parent2339ba5c77501a9fd8c96e8521df1e4668352fca (diff)
parent826ae444af550eb23c04e151e512f67a72284dd7 (diff)
downloadayatana-indicator-printers-d5699dd78605298f38bb9735d49e7b6d2d10fbd4.tar.gz
ayatana-indicator-printers-d5699dd78605298f38bb9735d49e7b6d2d10fbd4.tar.bz2
ayatana-indicator-printers-d5699dd78605298f38bb9735d49e7b6d2d10fbd4.zip
* New upstream release.
* Add test coverage build targets
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6e10cb9..40fd228 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -9,8 +9,11 @@ libprintersmenu_la_SOURCES = \
dbus-names.h
libprintersmenu_la_CPPFLAGS = $(APPLET_CFLAGS)
+libprintersmenu_la_CFLAGS = $(COVERAGE_CFLAGS)
libprintersmenu_la_LIBADD = $(APPLET_LIBS) -lm
-libprintersmenu_la_LDFLAGS = -module -avoid-version
+libprintersmenu_la_LDFLAGS = \
+ $(COVERAGE_LDFLAGS) \
+ -module -avoid-version
cups_notifier_sources = \
@@ -39,7 +42,9 @@ indicator_printers_service_SOURCES = \
nodist_indicator_printers_service_SOURCES = $(cups_notifier_sources)
indicator_printers_service_CPPFLAGS = $(SERVICE_CFLAGS)
+indicator_printers_service_CFLAGS = $(COVERAGE_CFLAGS)
indicator_printers_service_LDADD = $(SERVICE_LIBS)
+indicator_printers_service_LDFLAGS = $(COVERAGE_LDFLAGS)
BUILT_SOURCES = $(cups_notifier_sources)