aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-01-12 17:04:30 +0100
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-01-12 17:04:30 +0100
commiteda55d25b59b4ed7c373f37eb9004832f9e26367 (patch)
treeee817c63f6a61f9dade1721edb17dc4fc7b628a9 /src/Makefile.am
parent72ec836bd31f905d1191480e648252195aa5ec33 (diff)
downloadayatana-indicator-printers-eda55d25b59b4ed7c373f37eb9004832f9e26367.tar.gz
ayatana-indicator-printers-eda55d25b59b4ed7c373f37eb9004832f9e26367.tar.bz2
ayatana-indicator-printers-eda55d25b59b4ed7c373f37eb9004832f9e26367.zip
Move menu related code into a separate class
Also removes the "System Settings" menu item (according to spec). Printer menu items are hardcoded for now.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c5bdd52..5fc0107 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -13,7 +13,9 @@ libprintersmenu_la_LDFLAGS = -module -avoid-version
libexec_PROGRAMS = indicator-printers-service
indicator_printers_service_SOURCES = \
indicator-printers-service.c \
- indicator-printers-service.h
+ indicator-printers-service.h \
+ indicator-printers-menu.c \
+ indicator-printers-menu.h
indicator_printers_service_CPPFLAGS = $(SERVICE_CFLAGS)
indicator_printers_service_LDADD = $(SERVICE_LIBS)