aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-09-05 12:56:25 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-09-05 12:56:25 +0200
commite9534394c942cde1d043ce45f88f617b2018224f (patch)
tree0ecf0458b8b968eb8872deae2c73cd178b2fa97f /test/CMakeLists.txt
parent0ef8ce7677688b51ac69b3ba797f4d718f909f2f (diff)
parent9e5b57ca293414e51f82f70dd374b70798d08d44 (diff)
downloadayatana-indicator-printers-e9534394c942cde1d043ce45f88f617b2018224f.tar.gz
ayatana-indicator-printers-e9534394c942cde1d043ce45f88f617b2018224f.tar.bz2
ayatana-indicator-printers-e9534394c942cde1d043ce45f88f617b2018224f.zip
Merge branch 'tari01-pr/move-to-cmake'
Attributes GH PR #17: https://github.com/AyatanaIndicators/ayatana-indicator-printers/pull/17
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..78d8965
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,12 @@
+# cups-notifier.h
+# cups-notifier.c
+include (GdbusCodegen)
+add_gdbus_codegen_with_namespace (CUPS_NOTIFIER cups-notifier org.cups.cupsd Cups "${CMAKE_SOURCE_DIR}/src/org.cups.cupsd.Notifier.xml")
+
+# mock-cups-notifier
+add_executable (mock-cups-notifier mock-cups-notifier.c ${CUPS_NOTIFIER})
+target_include_directories (mock-cups-notifier PUBLIC ${SERVICE_INCLUDE_DIRS} ${CMAKE_CURRENT_BINARY_DIR})
+target_link_libraries (mock-cups-notifier ${SERVICE_LIBRARIES})
+add_test (mock-cups-notifier mock-cups-notifier)
+
+