aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 38e5fbc..c032912 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,5 @@
#!/usr/bin/make -f
-DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
CFLAGS += -Wno-error=deprecated-declarations
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
@@ -13,6 +12,10 @@ export DPKG_GENSYMBOLS_CHECK_LEVEL = 4
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --disable-static
+
override_dh_install:
find debian/indicator-printers -name \*.la -delete
find debian/indicator-printers -name \*.a -delete