aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog28
-rw-r--r--debian/control11
-rwxr-xr-xdebian/rules24
3 files changed, 46 insertions, 17 deletions
diff --git a/debian/changelog b/debian/changelog
index a595f5a..dae127e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,31 @@
+ayatana-indicator-printers (23.10.1-0) unstable; urgency=medium
+
+ * Upstream-provided Debian package for ayatana-indicator-printers.
+ See upstream ChangeLog for recent changes.
+
+ -- Mike Gabriel <mike.gabriel@das-netzwerkteam.de> Tue, 26 Dec 2023 13:10:02 +0100
+
+ayatana-indicator-printers (23.10.0-0) unstable; urgency=medium
+
+ * Upstream-provided Debian package for ayatana-indicator-printers.
+ See upstream ChangeLog for recent changes.
+
+ -- Mike Gabriel <mike.gabriel@das-netzwerkteam.de> Fri, 13 Oct 2023 08:24:46 +0200
+
+ayatana-indicator-printers (22.9.0-0) unstable; urgency=medium
+
+ * Upstream-provided Debian package for ayatana-indicator-printers.
+ See upstream ChangeLog for recent changes.
+
+ -- Mike Gabriel <mike.gabriel@das-netzwerkteam.de> Thu, 15 Dec 2022 21:48:08 +0100
+
+ayatana-indicator-printers (22.2.0-0) unstable; urgency=medium
+
+ * Upstream-provided Debian package for ayatana-indicator-printers.
+ See upstream ChangeLog for recent changes.
+
+ -- Mike Gabriel <mike.gabriel@das-netzwerkteam.de> Thu, 17 Feb 2022 22:26:01 +0100
+
ayatana-indicator-printers (0.9.0-0) unstable; urgency=medium
* Upstream-provided Debian package for ayatana-indicator-printers.
diff --git a/debian/control b/debian/control
index 3e98b9c..040ff2b 100644
--- a/debian/control
+++ b/debian/control
@@ -3,17 +3,14 @@ Section: x11
Priority: extra
Maintainer: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>
Build-Depends: debhelper (>= 10),
- autotools-dev,
- dh-autoreconf | debhelper (>= 9.20160403~),
+ cmake,
+ cmake-extras,
dh-systemd | debhelper (>= 10.2~),
dpkg-dev (>= 1.16.1.1),
- mate-common,
+ intltool,
libglib2.0-dev (>= 2.43.2),
- libgtk-3-dev,
- libdbusmenu-glib-dev (>= 0.5.90),
- libdbusmenu-gtk3-dev (>= 0.5.90),
- libayatana-indicator3-dev (>= 0.3.91),
libcups2-dev,
+ libayatana-common-dev,
systemd [linux-any],
Standards-Version: 4.1.1
Homepage: https://github.com/AyatanaIndicators/ayatana-indicator-printers
diff --git a/debian/rules b/debian/rules
index ba2e36f..fac96d4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,28 +1,32 @@
#!/usr/bin/make -f
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
-CFLAGS += -Wno-error=deprecated-declarations
-LDFLAGS += -Wl,-z,defs -Wl,--as-needed
+DEB_CMAKE_EXTRA_FLAGS = \
+ -DENABLE_TESTS=ON \
+ -DENABLE_COVERAGE=OFF \
+ $(NULL)
export DPKG_GENSYMBOLS_CHECK_LEVEL = 4
%:
- dh $@ --without autoreconf,systemd
+ dh $@ --with systemd
override_dh_auto_configure:
- NOCONFIGURE=1 ./autogen.sh
- dh_auto_configure -- \
- --disable-static
+ dh_auto_configure -- $(DEB_CMAKE_EXTRA_FLAGS)
override_dh_install:
find debian/ayatana-indicator-printers -name \*.la -delete
find debian/ayatana-indicator-printers -name \*.a -delete
dh_install --fail-missing
-override_dh_auto_clean:
- dh_auto_clean
- # no clue, why they don't disappear during make distclean...
- rm -f config.sub config.guess
+# Hack as it seems it's not possible to easy run that under dbus-test-runner
+override_dh_auto_test:
+ env -u LD_PRELOAD dh_auto_test
+
+get-orig-source:
+ uscan --noconf --force-download --rename --download-current-version --destdir=..