aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-11-14 22:07:18 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2015-11-14 23:16:37 +0100
commit405a6969a0b2409d5f013e8d2845945b51146eb9 (patch)
tree367704fccc48a88d87eada791b6813f10b89fb0d /CMakeLists.txt
parentc5211a8f81f6704558f4453c5eeb509f29672781 (diff)
downloadayatana-indicator-session-405a6969a0b2409d5f013e8d2845945b51146eb9.tar.gz
ayatana-indicator-session-405a6969a0b2409d5f013e8d2845945b51146eb9.tar.bz2
ayatana-indicator-session-405a6969a0b2409d5f013e8d2845945b51146eb9.zip
Fork from Ubuntu's indicator-session project.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72d9a5a..fb96e29 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,11 +1,11 @@
-project (indicator-session C CXX)
+project (ayatana-indicator-session C CXX)
cmake_minimum_required (VERSION 2.8.9)
list (APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
-set (PROJECT_VERSION "13.10.1")
+set (PROJECT_VERSION "0.5.0")
set (PACKAGE ${CMAKE_PROJECT_NAME})
-set (GETTEXT_PACKAGE indicator-session)
+set (GETTEXT_PACKAGE ayatana-indicator-session)
option (enable_tests "Build the package's automatic tests." ON)
option (enable_lcov "Generate lcov code coverage reports." ON)
@@ -29,8 +29,7 @@ find_package (PkgConfig REQUIRED)
include (FindPkgConfig)
pkg_check_modules (SERVICE REQUIRED
glib-2.0>=2.36
- gio-unix-2.0>=2.36
- url-dispatcher-1>=1)
+ gio-unix-2.0>=2.36)
include_directories (${SERVICE_INCLUDE_DIRS})
set (CC_WARNING_ARGS " -Wall -pedantic -Wextra -Wno-missing-field-initializers")