aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-07-01 19:02:47 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-07-01 19:02:47 -0500
commit477dc6fa22bcd37b23deb45b57bec6518ba52ad9 (patch)
treebc8d5b60f2b175e883be546b2cef46f50afb807c /CMakeLists.txt
parent6ee61b9bb4d92e5c9a41d2259e879486ec0d730a (diff)
downloadayatana-indicator-session-477dc6fa22bcd37b23deb45b57bec6518ba52ad9.tar.gz
ayatana-indicator-session-477dc6fa22bcd37b23deb45b57bec6518ba52ad9.tar.bz2
ayatana-indicator-session-477dc6fa22bcd37b23deb45b57bec6518ba52ad9.zip
in the cmake files, prefer the _FULL versions of the GNU variables
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 593d916..25c2be1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,8 +46,8 @@ include_directories (${CMAKE_CURRENT_BINARY_DIR}/src)
# Workaround for libexecdir on debian
if (EXISTS "/etc/debian_version")
- set (CMAKE_INSTALL_LIBEXECDIR ${CMAKE_INSTALL_LIBDIR})
- set (CMAKE_INSTALL_FULL_LIBEXECDIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBEXECDIR}")
+ set (CMAKE_INSTALL_LIBEXECDIR "${CMAKE_INSTALL_LIBDIR}")
+ set (CMAKE_INSTALL_FULL_LIBEXECDIR "${CMAKE_INSTALL_FULL_LIBDIR}")
endif ()
set (PROJECT_LIBEXECDIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
message (STATUS "${PROJECT_LIBEXECDIR} is the libexec install dir")