aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-06-20 18:43:38 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-06-20 18:43:38 -0500
commit59caa78d5ac6410fea8da709189f41fa86e6a2a7 (patch)
treea5d48fedab370b853e82f2da091447332254595c /CMakeLists.txt
parent452ac8d007d55ef282546c0ee3871bf50dd49917 (diff)
downloadayatana-indicator-session-59caa78d5ac6410fea8da709189f41fa86e6a2a7.tar.gz
ayatana-indicator-session-59caa78d5ac6410fea8da709189f41fa86e6a2a7.tar.bz2
ayatana-indicator-session-59caa78d5ac6410fea8da709189f41fa86e6a2a7.zip
cmake: cleanup, move DBUSSERVICEDIR's scope from global to the data/ dir
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 4 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d90d6c9..1299319 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,19 +47,11 @@ include_directories (${CMAKE_CURRENT_BINARY_DIR}/src)
# Workaround for libexecdir on debian
if (EXISTS "/etc/debian_version")
- set(CMAKE_INSTALL_LIBEXECDIR ${CMAKE_INSTALL_LIBDIR})
- set(CMAKE_INSTALL_FULL_LIBEXECDIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBEXECDIR}")
-endif()
-message("Installing libexec files to ${CMAKE_INSTALL_FULL_LIBEXECDIR}")
+ set (CMAKE_INSTALL_LIBEXECDIR ${CMAKE_INSTALL_LIBDIR})
+ set (CMAKE_INSTALL_FULL_LIBEXECDIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBEXECDIR}")
+endif ()
set (PROJECT_LIBEXECDIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
-
-if(${LOCAL_INSTALL})
- set(DBUSSERVICEDIR "${CMAKE_INSTALL_DATADIR}/dbus-1/services/")
-else()
- EXEC_PROGRAM(${PKG_CONFIG_EXECUTABLE} ARGS dbus-1 --variable session_bus_services_dir OUTPUT_VARIABLE DBUSSERVICEDIR )
-endif()
-message("Installing DBus services to ${DBUSSERVICEDIR}")
-
+message (STATUS "${PROJECT_LIBEXECDIR} is the libexec install dir")
add_subdirectory (src)
add_subdirectory (data)