aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-06-20 17:31:07 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-06-20 17:31:07 -0500
commit6def7fceae5ea55e6d44ede05146f6a95add317c (patch)
treedba817e06dd9cb1a367b0cf4c4a2dd902ad34862 /CMakeLists.txt
parenta5fb857ee48a9022eb1e6c9ea04e0aeff80f445b (diff)
downloadayatana-indicator-session-6def7fceae5ea55e6d44ede05146f6a95add317c.tar.gz
ayatana-indicator-session-6def7fceae5ea55e6d44ede05146f6a95add317c.tar.bz2
ayatana-indicator-session-6def7fceae5ea55e6d44ede05146f6a95add317c.zip
install .schema.xml and indicator-session-service in the right places.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f656cb4..d90d6c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,7 @@ find_package(PkgConfig REQUIRED)
include (GNUInstallDirs)
include (FindPkgConfig)
include (GdbusCodegen)
-include (GSettings)
+include (UseGSettings)
add_definitions( -DGETTEXT_PACKAGE="${GETTEXT_PACKAGE}" )
add_definitions (-DGNOMELOCALEDIR=\"@CMAKE_INSTALL_PREFIX@/share/locale\")
@@ -51,6 +51,7 @@ if (EXISTS "/etc/debian_version")
set(CMAKE_INSTALL_FULL_LIBEXECDIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBEXECDIR}")
endif()
message("Installing libexec files to ${CMAKE_INSTALL_FULL_LIBEXECDIR}")
+set (PROJECT_LIBEXECDIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
if(${LOCAL_INSTALL})
set(DBUSSERVICEDIR "${CMAKE_INSTALL_DATADIR}/dbus-1/services/")