aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-08-12 12:01:00 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-08-12 12:01:00 -0500
commit752149b96a3b78937fee7d95ef119df8bb6b7c52 (patch)
treef3bfdb1cf6752890089176cc63942e5de42d93e7 /CMakeLists.txt
parentaf1b85a001162fe3172de25bd14eb245c259d0e5 (diff)
downloadayatana-indicator-session-752149b96a3b78937fee7d95ef119df8bb6b7c52.tar.gz
ayatana-indicator-session-752149b96a3b78937fee7d95ef119df8bb6b7c52.tar.bz2
ayatana-indicator-session-752149b96a3b78937fee7d95ef119df8bb6b7c52.zip
in CMakeLists.txt, include the GCov rules before adding the src subdirectory. This unbreaks coverage report generation.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8a366b..69ac18e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,18 +49,20 @@ add_custom_target (cppcheck COMMAND cppcheck --enable=all -q --error-exitcode=2
include_directories (${CMAKE_CURRENT_SOURCE_DIR}/src)
include_directories (${CMAKE_CURRENT_BINARY_DIR}/src)
-
-add_subdirectory (src)
-add_subdirectory (data)
-add_subdirectory (po)
-
+# testing & coverage
if (${enable_tests})
set (GTEST_SOURCE_DIR /usr/src/gtest/src)
set (GTEST_INCLUDE_DIR ${GTEST_SOURCE_DIR}/..)
set (GTEST_LIBS -lpthread)
enable_testing ()
if (${enable_lcov})
- include(cmake/GCov.cmake)
+ include(GCov)
endif ()
- add_subdirectory(tests)
+endif ()
+
+add_subdirectory (src)
+add_subdirectory (data)
+add_subdirectory (po)
+if (${enable_tests})
+ add_subdirectory (tests)
endif ()