aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-07-24 12:32:26 +0200
committerRobert Tari <robert@tari.in>2020-07-24 18:51:02 +0200
commit8b106227aeff804d06a50210dac65f9986929721 (patch)
tree4aefa80b0ea1e0358b83352e2192110dd69c2e96 /CMakeLists.txt
parentb0e201ca15cfc6960ca53038ffd4d04a5e57dfca (diff)
downloadayatana-indicator-session-8b106227aeff804d06a50210dac65f9986929721.tar.gz
ayatana-indicator-session-8b106227aeff804d06a50210dac65f9986929721.tar.bz2
ayatana-indicator-session-8b106227aeff804d06a50210dac65f9986929721.zip
CMakeLists.txt: Drop workaround for missing libexec dir on Debian. Debian moved forward and now supports FHS 3.0 (since Debian Policy 4.1.5).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a9a73b5..a56d94c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,10 +14,6 @@ option (enable_lcov "Generate lcov code coverage reports." ON)
## GNU standard installation directories
##
include (GNUInstallDirs)
-if (EXISTS "/etc/debian_version") # Workaround for libexecdir on debian
- set (CMAKE_INSTALL_LIBEXECDIR "${CMAKE_INSTALL_LIBDIR}")
- set (CMAKE_INSTALL_FULL_LIBEXECDIR "${CMAKE_INSTALL_FULL_LIBDIR}")
-endif ()
set (CMAKE_INSTALL_PKGLIBEXECDIR "${CMAKE_INSTALL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
set (CMAKE_INSTALL_FULL_PKGLIBEXECDIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")