aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-12-17 09:55:43 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-01-27 09:36:36 +0100
commit904438acf7d91cd7ec27e7e348d8ffa2b67e42f3 (patch)
treea4ab8a1c5e27dde146a0cb61ec09c6066578aa20 /CMakeLists.txt
parent1ea9f8bdeb14b770a98a6f33d548d51bfed72cb8 (diff)
downloadayatana-indicator-session-904438acf7d91cd7ec27e7e348d8ffa2b67e42f3.tar.gz
ayatana-indicator-session-904438acf7d91cd7ec27e7e348d8ffa2b67e42f3.tar.bz2
ayatana-indicator-session-904438acf7d91cd7ec27e7e348d8ffa2b67e42f3.zip
Fix code to build with -Werror
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1dbe04d..7195c77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,8 @@ if(ENABLE_WERROR)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
endif()
+add_definitions("-Wno-sign-compare") # Needed for GTest on Ubuntu
+
##
## GNU standard installation directories
##