aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-11-02 13:48:48 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-11-02 13:48:48 +0100
commitba840e537b10fb4b0a9a6f8c2d4708ee0b525d21 (patch)
tree7e202266f2f687f3714b6bd81c411fe7f72ec8fc /CMakeLists.txt
parent9e19aaef2031739d8ddba99aafc8f9f2d5d740fd (diff)
downloadayatana-indicator-session-ba840e537b10fb4b0a9a6f8c2d4708ee0b525d21.tar.gz
ayatana-indicator-session-ba840e537b10fb4b0a9a6f8c2d4708ee0b525d21.tar.bz2
ayatana-indicator-session-ba840e537b10fb4b0a9a6f8c2d4708ee0b525d21.zip
{CMakeLists.txt,src/service.c}: Make building against librda optional.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 13 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c14ca59..848a1df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ set (GETTEXT_PACKAGE "ayatana-indicator-session")
option(ENABLE_TESTS "Enable all tests and checks" OFF)
option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
+option(ENABLE_RDA "Enable RDA (remote desktop awareness)" ON)
if(ENABLE_COVERAGE)
set(ENABLE_TESTS ON)
@@ -45,11 +46,18 @@ include (GNUInstallDirs)
##
find_package (PkgConfig REQUIRED)
include (FindPkgConfig)
-pkg_check_modules (SERVICE REQUIRED
- libayatana-common>=0.9.2
- glib-2.0>=2.36
- gio-unix-2.0>=2.36
- rda)
+set (SERVICE REQUIRED
+ libayatana-common>=0.9.2
+ glib-2.0>=2.36
+ gio-unix-2.0>=2.36)
+
+if (ENABLE_RDA)
+ list (APPEND SERVICE rda)
+ add_definitions (-DRDA_ENABLED)
+endif ()
+
+pkg_check_modules (SERVICE REQUIRED ${SERVICE})
+
include_directories (${SERVICE_INCLUDE_DIRS})
set (ARCHIVE_NAME ${CMAKE_PROJECT_NAME}-${PROJECT_VERSION})