aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-04-27 15:17:47 -0500
committerCharles Kerr <charles.kerr@canonical.com>2012-04-27 15:17:47 -0500
commitea22a6005cd8c2c07447bb7303f542d4e00570ad (patch)
tree3094cc3300bda1559998bc9b1dcda89d08d711af /configure.ac
parent1bab86efd3e4637d61e20364c2859982605850b1 (diff)
parentf2298244150295340ce53a35ea6ff92433105f2c (diff)
downloadayatana-indicator-session-ea22a6005cd8c2c07447bb7303f542d4e00570ad.tar.gz
ayatana-indicator-session-ea22a6005cd8c2c07447bb7303f542d4e00570ad.tar.bz2
ayatana-indicator-session-ea22a6005cd8c2c07447bb7303f542d4e00570ad.zip
use ted's suggestions for using xorg-gtest and to remove the service-test-runner.sh script
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e90a05e..de54ff4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,13 +183,14 @@ AC_ARG_ENABLE([tests],
if test "x$enable_tests" != "xno"; then
m4_include([m4/gtest.m4])
CHECK_GTEST
+ CHECK_XORG_GTEST
if test "x$enable_tests" = "xauto"; then
enable_tests=${have_gtest}
elif test "x$enable_tests" = "xyes" && test "x$have_gtest" != "xyes"; then
AC_MSG_ERROR([tests were requested but gtest is not installed.])
fi
if test "x$enable_tests" = "xyes"; then
- PKG_CHECK_MODULES([TEST_SERVICE],[indicator-0.4 >= $INDICATOR_REQUIRED_VERSION
+ PKG_CHECK_MODULES([TEST_SERVICE],[indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
dbustest-1 >= $DBUSTEST_REQUIRED_VERSION
dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION])
fi