aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2013-06-20 18:06:06 -0500
committerCharles Kerr <charles.kerr@canonical.com>2013-06-20 18:06:06 -0500
commit452ac8d007d55ef282546c0ee3871bf50dd49917 (patch)
tree32504557dd1e8558f50b2e4fce49b549aac446f3 /data/CMakeLists.txt
parent6def7fceae5ea55e6d44ede05146f6a95add317c (diff)
downloadayatana-indicator-session-452ac8d007d55ef282546c0ee3871bf50dd49917.tar.gz
ayatana-indicator-session-452ac8d007d55ef282546c0ee3871bf50dd49917.tar.bz2
ayatana-indicator-session-452ac8d007d55ef282546c0ee3871bf50dd49917.zip
add cmake rules to install the icon files
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index d8f338b..de6942d 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -40,3 +40,18 @@ set (UNITY_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/share/unity")
install (FILES ${UNITY_INDICATOR_PATH} DESTINATION "${UNITY_INSTALL_PREFIX}/indicators")
+
+##
+## Icons
+##
+
+if(${LOCAL_INSTALL})
+ set (ICON_PREFIX "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATADIR}/libindicator/icons/")
+else()
+ EXEC_PROGRAM(${PKG_CONFIG_EXECUTABLE} ARGS indicator3-0.4 --variable iconsdir OUTPUT_VARIABLE ICON_PREFIX)
+endif()
+set (ICON_DIR "${ICON_PREFIX}/hicolor")
+message ("Installing icons to ${ICON_DIR}")
+install (DIRECTORY icons
+ DESTINATION ${ICON_DIR}
+ FILES_MATCHING PATTERN "*.png" PATTERN "*.svg")