aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2012-02-07 21:14:45 -0600
committerTed Gould <ted@gould.cx>2012-02-07 21:14:45 -0600
commitc49024a21eb6d36afe67fc5bd6eead55e7bfbbc7 (patch)
tree2e8148be67c0d980232be867fb1ff78406444f84 /data/Makefile.am
parent669d032147326fadfd606eb22efd5ca3e5c4d39a (diff)
parent455f5df69319c0feb5e64317bef16925623e8ac5 (diff)
downloadayatana-indicator-session-c49024a21eb6d36afe67fc5bd6eead55e7bfbbc7.tar.gz
ayatana-indicator-session-c49024a21eb6d36afe67fc5bd6eead55e7bfbbc7.tar.bz2
ayatana-indicator-session-c49024a21eb6d36afe67fc5bd6eead55e7bfbbc7.zip
* New upstream release.
* Screensaver code cleanup * Fix ordering of items on request * Removing GOA support * Fix GTK3 Box Deprecation * Updating to dbusmenu 0.5.90 * Making the gtk logout helper and apt optional build time choices * Add name hints to the indicators * bump version for release
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am20
1 files changed, 12 insertions, 8 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 7e851a7..3b8de1f 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -18,6 +18,15 @@ gsettings_SCHEMAS = com.canonical.indicator.session.gschema.xml
convertdir = $(datadir)/GConf/gsettings
dist_convert_DATA = indicator-session.convert
+EXTRA_DIST = \
+ $(service_in_files) \
+ $(gsettings_SCHEMAS:.xml=.xml.in)
+
+CLEANFILES = \
+ $(dbus_services_DATA) \
+ $(gsettings_SCHEMAS)
+
+if BUILD_GTKLOGOUTHELPER
@INTLTOOL_DESKTOP_RULE@
%.desktop.in: %.desktop.in.in
@@ -37,14 +46,9 @@ logout_helper_desktop_files = \
$(logout_helper_desktop_in_in_files:.desktop.in.in=.desktop)
logout_helper_DATA = $(logout_helper_desktop_files)
-EXTRA_DIST = \
- $(service_in_files) \
- $(gsettings_SCHEMAS:.xml=.xml.in) \
+EXTRA_DIST += \
$(logout_helper_desktop_in_in_files)
-
-CLEANFILES = \
- $(dbus_services_DATA) \
- $(gsettings_SCHEMAS) \
+CLEANFILES += \
$(logout_helper_desktop_files)
-
+endif