aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSebastien Bacher <seb128@ubuntu.com>2012-07-11 19:53:59 +0200
committerSebastien Bacher <seb128@ubuntu.com>2012-07-11 19:53:59 +0200
commit7a6621d316ea0825de80548f6d8db81e98f56099 (patch)
treef0348b62daae64b69ce9ae1390c2088267d1f9f4 /debian/rules
parent58b72505bad696704ad01e749830196400339ad5 (diff)
parente1ec25c1ccc63162bcfefc0661fc61fac9f376d1 (diff)
downloadayatana-indicator-session-7a6621d316ea0825de80548f6d8db81e98f56099.tar.gz
ayatana-indicator-session-7a6621d316ea0825de80548f6d8db81e98f56099.tar.bz2
ayatana-indicator-session-7a6621d316ea0825de80548f6d8db81e98f56099.zip
releasing version 12.10.0-0ubuntu1
Diffstat (limited to 'debian/rules')
-rw-r--r--debian/rules19
1 files changed, 4 insertions, 15 deletions
diff --git a/debian/rules b/debian/rules
index 43ffda2..8534cd9 100644
--- a/debian/rules
+++ b/debian/rules
@@ -1,31 +1,20 @@
#!/usr/bin/make -f
-DEB_BUILDDIR = build
-DEB_MAKE_FLAVORS = gtk2 gtk3
-
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
-DEB_MAKE_DESTDIRSKEL = $(CURDIR)/debian/tmp/@FLAVOR@
-DEB_DESTDIR = $(CURDIR)/debian/tmp/$(cdbs_make_curflavor)/
-
-DEB_CONFIGURE_FLAGS_gtk2 = --with-gtk=2
-DEB_CONFIGURE_FLAGS_gtk3 = --with-gtk=3
DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
CFLAGS += -Wno-error=deprecated-declarations
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)
-debian/stamp-autotools/gtk3: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk3)
-
common-install-arch::
- find debian/tmp -name \*.la -delete
- find debian/tmp -name \*.a -delete
- find debian/tmp -name classic-desktop.sh | xargs chmod +x
+ find debian/indicator-session -name \*.la -delete
+ find debian/indicator-session -name \*.a -delete
+ find debian/indicator-session -name classic-desktop.sh | xargs chmod +x
cd po; intltool-update --pot --verbose
# Language packs
- for d in $$(find debian/tmp -type f \( -name "*.desktop" -o -name "*.directory" \) ); do \
+ for d in $$(find debian/indicator-session -type f \( -name "*.desktop" -o -name "*.directory" \) ); do \
sed -ri '/^(Name|GenericName|Comment|X-GNOME-FullName)\[/d' $$d; \
echo "X-Ubuntu-Gettext-Domain=indicator-session" >> $$d; \
done;