aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2009-12-08 11:04:51 -0500
committerKen VanDine <ken.vandine@canonical.com>2009-12-08 11:04:51 -0500
commit32e8874eb5db15d4b14afbe4966c4ba92e717c36 (patch)
treea07549171cf9716e3721052e4aae1f707a80ad00 /debian
parent0ff1e5f572325fe855290f26b4281819fbb4e0e3 (diff)
downloadayatana-indicator-session-32e8874eb5db15d4b14afbe4966c4ba92e717c36.tar.gz
ayatana-indicator-session-32e8874eb5db15d4b14afbe4966c4ba92e717c36.tar.bz2
ayatana-indicator-session-32e8874eb5db15d4b14afbe4966c4ba92e717c36.zip
* debian/patches/03_tp_glib.patch
- Updated patch to properly work with TpAccountManager
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/03_tp_glib.patch49
2 files changed, 47 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 93dc131..69760fd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+indicator-session (0.1.7-0ubuntu5) lucid; urgency=low
+
+ * debian/patches/03_tp_glib.patch
+ - Updated patch to properly work with TpAccountManager
+
+ -- Ken VanDine <ken.vandine@canonical.com> Tue, 08 Dec 2009 11:01:38 -0500
+
indicator-session (0.1.7-0ubuntu4) lucid; urgency=low
* debian/patches/02_mc5-fixes.patch
diff --git a/debian/patches/03_tp_glib.patch b/debian/patches/03_tp_glib.patch
index ce06de6..82e35ae 100644
--- a/debian/patches/03_tp_glib.patch
+++ b/debian/patches/03_tp_glib.patch
@@ -17,13 +17,13 @@
=== modified file 'src/status-provider-mc5.c'
--- src/status-provider-mc5.c 2009-12-08 13:38:42 +0000
-+++ src/status-provider-mc5.c 2009-12-08 14:06:05 +0000
++++ src/status-provider-mc5.c 2009-12-08 16:01:06 +0000
@@ -24,7 +24,7 @@
#include "config.h"
#endif
-#include "libempathy/empathy-account-manager.h"
-+#include "telepathy-glib/account-manager.h"
++#include <telepathy-glib/account-manager.h>
#include "status-provider.h"
#include "status-provider-mc5.h"
@@ -45,13 +45,43 @@
static void dbus_namechange (DBusGProxy * proxy, const gchar * name, const gchar * prev, const gchar * new, StatusProviderMC5 * self);
static void mc5_exists_cb (DBusGProxy * proxy, gboolean exists, GError * error, gpointer userdata);
-@@ -120,14 +120,14 @@
+@@ -109,25 +109,41 @@
+ return;
+ }
+
+-/* Build our empathy account manager instance if we don't
++/* Build our telepathy account manager instance if we don't
+ have one. */
+ static void
+ build_eam (StatusProviderMC5 * self)
+ {
+ StatusProviderMC5Private * priv = STATUS_PROVIDER_MC5_GET_PRIVATE(self);
++ static TpDBusDaemon *daemon = NULL;
++ GError *error = NULL;
+
+ if (priv->manager != NULL) {
return;
}
-
+-
- priv->manager = EMPATHY_ACCOUNT_MANAGER(g_object_new(EMPATHY_TYPE_ACCOUNT_MANAGER, NULL));
-+ priv->manager = TP_ACCOUNT_MANAGER(g_object_new(TP_TYPE_ACCOUNT_MANAGER, NULL));
- g_signal_connect(G_OBJECT(priv->manager), "global-presence-changed", G_CALLBACK(presence_changed), self);
+- g_signal_connect(G_OBJECT(priv->manager), "global-presence-changed", G_CALLBACK(presence_changed), self);
++ /* the daemon is used to communicate via DBus */
++ daemon = tp_dbus_daemon_dup(&error);
++
++ if (daemon == NULL)
++ {
++ g_debug("Cannot create DBus daemon: %s\n", error->message);
++ g_error_free(error);
++ return;
++ }
++
++ priv->manager = TP_ACCOUNT_MANAGER (g_object_new (TP_TYPE_ACCOUNT_MANAGER,
++ "dbus-daemon", daemon,
++ "dbus-connection", ((TpProxy *) daemon)->dbus_connection,
++ "bus-name", "org.freedesktop.Telepathy.MissionControl5",
++ "object-path", "/org/freedesktop/Telepathy/AccountManager",
++ NULL));
++ g_signal_connect(G_OBJECT(priv->manager), "most-available-presence-changed", G_CALLBACK(presence_changed), self);
return;
}
@@ -62,16 +92,17 @@
work in this module of tracking MissionControl and enumerating the
accounts and all that jazz. */
static void
-@@ -267,7 +267,7 @@
+@@ -266,8 +282,7 @@
+ StatusProviderMC5Private * priv = STATUS_PROVIDER_MC5_GET_PRIVATE(sp);
build_eam(STATUS_PROVIDER_MC5(sp));
-
+-
- empathy_account_manager_request_global_presence(priv->manager, sp_to_tp_map[status], sp_to_mc_map[status], "");
+ tp_account_manager_set_all_requested_presences(priv->manager, sp_to_tp_map[status], sp_to_mc_map[status], "");
return;
}
-@@ -287,11 +287,11 @@
+@@ -287,11 +302,11 @@
return priv->status;
}