aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 20:56:24 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 20:56:24 +0100
commitf4af8fcf5beb28517f5c813e37607b289d2523d3 (patch)
treee91e9a6e9f0c3b99e557082aec26b9c9188ce53c /debian
parent6fc47748435787e99bdf2843358d2a4c78c79cbd (diff)
downloadayatana-indicator-session-f4af8fcf5beb28517f5c813e37607b289d2523d3.tar.gz
ayatana-indicator-session-f4af8fcf5beb28517f5c813e37607b289d2523d3.tar.bz2
ayatana-indicator-session-f4af8fcf5beb28517f5c813e37607b289d2523d3.zip
debian/{control,postinst}: Recompile GSettings schemas at post installation.
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/postinst40
2 files changed, 41 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index dc3c3d5..bce329d 100644
--- a/debian/control
+++ b/debian/control
@@ -24,6 +24,7 @@ Depends: ayatana-indicator-common,
systemd [linux-any],
${misc:Depends},
${shlibs:Depends},
+ glib2.0-bin,
Recommends: gnome-screensaver | mate-screensaver,
mate-indicator-applet | xfce4-indicator-plugin | indicator-renderer,
unity-control-center | gnome-control-center | mate-control-center,
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..bdf5b42
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,40 @@
+#!/bin/sh
+# postinst script for ayatana-indicator-systemtray
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ configure)
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0