aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-25 22:59:59 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-25 22:59:59 +0200
commitc00d3d13b07ed6fa60ac975c2e633e2e5a3cbee3 (patch)
tree2983d9c84d009a388b2bac49a12cddcc4622c890 /src/CMakeLists.txt
parent80a129dd5fcbaf0e8086a3c57f3ee0667c9ae0fc (diff)
downloadayatana-indicator-session-c00d3d13b07ed6fa60ac975c2e633e2e5a3cbee3.tar.gz
ayatana-indicator-session-c00d3d13b07ed6fa60ac975c2e633e2e5a3cbee3.tar.bz2
ayatana-indicator-session-c00d3d13b07ed6fa60ac975c2e633e2e5a3cbee3.zip
Reintroduce optional url-dispatcher support.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2a3acfd..7ee1692 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -16,13 +16,17 @@ add_library (libayatanaindicatorsessionservice STATIC
include_directories(${SERVICE_INCLUDE_DIRS})
link_directories(${SERVICE_LIBRARY_DIRS})
+if(URLDISPATCHER_FOUND)
+ add_definitions( -DHAS_URLDISPATCHER )
+endif()
+
set (SERVICE_EXEC "ayatana-indicator-session-service")
set_property (SOURCE main.c
APPEND PROPERTY COMPILE_DEFINITIONS
GETTEXT_PACKAGE="${GETTEXT_PACKAGE}"
LOCALEDIR="${CMAKE_INSTALL_FULL_LOCALEDIR}")
add_executable (${SERVICE_EXEC} main.c)
-target_link_libraries (${SERVICE_EXEC} libayatanaindicatorsessionservice backenddbus ${SERVICE_LIBRARIES} ${GCOV_LIBS})
+target_link_libraries (${SERVICE_EXEC} libayatanaindicatorsessionservice backenddbus ${SERVICE_LIBRARIES} ${GCOV_LIBS} ${URLDISPATCHER_LIBRARIES})
install (TARGETS ${SERVICE_EXEC} RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_PKGLIBEXECDIR})
# common properties