aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-11-29 16:19:34 -0600
committerTed Gould <ted@gould.cx>2011-11-29 16:19:34 -0600
commit77699eb5a22ed5da6b008368486121e9ef7fc4e0 (patch)
tree775c03375ff3bb04e7482b123459c1acf899d9a4 /src/Makefile.am
parentdba878e3338b85c6c3e121b738448f687941e03e (diff)
parentb3d54d8b5d90cdaaa7169a25e9c9a8823d6ef61c (diff)
downloadayatana-indicator-session-77699eb5a22ed5da6b008368486121e9ef7fc4e0.tar.gz
ayatana-indicator-session-77699eb5a22ed5da6b008368486121e9ef7fc4e0.tar.bz2
ayatana-indicator-session-77699eb5a22ed5da6b008368486121e9ef7fc4e0.zip
Making the gtk logout helper and apt optional build time choices
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 16 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index dba0a9e..afee66c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,11 @@
libexec_PROGRAMS = \
- indicator-session-service \
+ indicator-session-service
+
+if BUILD_GTKLOGOUTHELPER
+libexec_PROGRAMS += \
gtk-logout-helper
+endif
###################
# Indicator Stuff
@@ -103,13 +107,18 @@ indicator_session_service_SOURCES = \
user-menu-mgr.c \
device-menu-mgr.h \
device-menu-mgr.c \
- apt-watcher.h \
- apt-watcher.c \
- apt-transaction.h \
- apt-transaction.c \
udev-mgr.h \
udev-mgr.c \
sane-rules.h
+
+if BUILD_APT
+indicator_session_service_SOURCES += \
+ apt-watcher.h \
+ apt-watcher.c \
+ apt-transaction.h \
+ apt-transaction.c
+endif
+
indicator_session_service_CFLAGS = \
$(SESSIONSERVICE_CFLAGS) \
$(GCONF_CFLAGS) \
@@ -124,6 +133,7 @@ indicator_session_service_LDADD = \
# GTK Logout Stuff
#################
+if BUILD_GTKLOGOUTHELPER
gtk_logout_helper_SOURCES = \
gtk-logout-helper.c \
settings-helper.c \
@@ -142,6 +152,7 @@ gtk_logout_helper_LDADD = \
$(SESSIONSERVICE_LIBS) \
$(GTKLOGOUTHELPER_LIBS) \
$(GCONF_LIBS)
+endif
###############