aboutsummaryrefslogtreecommitdiff
path: root/src/backend-dbus/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-02-13 22:02:46 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2023-02-13 22:57:53 +0100
commit8c4df6215a986695edc6c6530f6d6388ea9640d5 (patch)
treeedbaa4c0de4c25d7e6ba5f2db9f46b819b6e6699 /src/backend-dbus/CMakeLists.txt
parentf9d1e0d63e454dbd280342ea42aa741d7a6a2003 (diff)
downloadayatana-indicator-session-8c4df6215a986695edc6c6530f6d6388ea9640d5.tar.gz
ayatana-indicator-session-8c4df6215a986695edc6c6530f6d6388ea9640d5.tar.bz2
ayatana-indicator-session-8c4df6215a986695edc6c6530f6d6388ea9640d5.zip
UnitySession -> LomiriSession: Re-rename related changes that we erroneously hid away as Ayatana DesktopSession.
This brings full Lomiri integration finally. Until now, the session indicator somehow seemed to work, but in some odd ways. On the phone, the session indicator would fallback to direct systemd interaction while on Lomiri in Debian, it would fallback to Zenity dialogs (most of all because Zenity got installed by some other package as a dependency). With this massive renaming change, ayatana-indicator-session should now smoothly interact with the com.lomiri.Shell.Session DBus interface and also with the mimicked GNOME SessionManager End-Session-Dialog interface. As a downside, this change nearly fully removes Unity7 support which would need to be brought back +/- as a full duplicate of what we do for Lomiri. But as noone has dared integrating Ayatana Indicator Session with Unity7, so far, we should be able to live with that for now. Fixes https://github.com/AyatanaIndicators/ayatana-indicator-session/issues/82
Diffstat (limited to 'src/backend-dbus/CMakeLists.txt')
-rw-r--r--src/backend-dbus/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/backend-dbus/CMakeLists.txt b/src/backend-dbus/CMakeLists.txt
index 5c99e9f..bd87e27 100644
--- a/src/backend-dbus/CMakeLists.txt
+++ b/src/backend-dbus/CMakeLists.txt
@@ -43,9 +43,10 @@ add_gdbus_codegen (BACKEND_GENERATED_SOURCES dbus-end-session-dialog
org.gnome.SessionManager
${CMAKE_CURRENT_SOURCE_DIR}/org.gnome.SessionManager.EndSessionDialog.xml)
-add_gdbus_codegen (BACKEND_GENERATED_SOURCES desktop-session
- org.ayatana
- ${CMAKE_CURRENT_SOURCE_DIR}/org.ayatana.Desktop.Session.xml)
+add_gdbus_codegen_with_namespace (BACKEND_GENERATED_SOURCES lomiri-session
+ com.lomiri
+ Lomiri
+ ${CMAKE_CURRENT_SOURCE_DIR}/com.lomiri.Shell.Session.xml)
set (SOURCES actions.c guest.c users.c backend-dbus.c utils.c)