aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-04 16:10:41 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-05-04 16:10:41 +0200
commit09c1a589f6936c8b08c76d5f822af592b3363722 (patch)
treefbda6483952997b1d30640404a3f23cfbb9a4f6c /tests/CMakeLists.txt
parent0a3f7f64748886969d215741dcf23fe7bc8a99a4 (diff)
downloadayatana-indicator-session-09c1a589f6936c8b08c76d5f822af592b3363722.tar.gz
ayatana-indicator-session-09c1a589f6936c8b08c76d5f822af592b3363722.tar.bz2
ayatana-indicator-session-09c1a589f6936c8b08c76d5f822af592b3363722.zip
.travis.yml: Don't try running autotools based CI build.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 2b4bdcc..4bd5a8a 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -3,6 +3,8 @@ set_directory_properties (PROPERTIES
ADDITIONAL_MAKE_CLEAN_FILES gschemas.compiled)
set_source_files_properties (gschemas.compiled GENERATED)
+SET(COVERAGE_TEST_TARGETS "")
+
# GSettings:
# compile the schemas our tests use (ayatana-indicator-session's, lockdown, media-keys)
# into a gschemas.compiled file in this directory, and help the tests to find
@@ -53,4 +55,6 @@ add_test (test-service test-service)
add_dependencies (test-service libayatanaindicatorsessionservice backendmock gschemas-compiled)
target_link_libraries (test-service libayatanaindicatorsessionservice backendmock gtest ${SERVICE_LIBRARIES} ${GTEST_LIBS})
+SET(COVERAGE_TEST_TARGETS "${COVERAGE_TEST_TARGETS} test-service")
+
add_subdirectory (backend-dbus)