aboutsummaryrefslogtreecommitdiff
path: root/tests/backend-dbus/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-10 21:55:02 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-10 21:55:02 +0200
commitce534e84c417692ee1a6a014defaccb17849ee09 (patch)
tree28841d20fa441e28acc1f4911579ff0208770b79 /tests/backend-dbus/CMakeLists.txt
parentd9340bfd47aaf6c6ff584929987ce1dd46caf0b5 (diff)
parent6472b6f79c7bada6d7d18891d7d6333196e454e8 (diff)
downloadayatana-indicator-session-ce534e84c417692ee1a6a014defaccb17849ee09.tar.gz
ayatana-indicator-session-ce534e84c417692ee1a6a014defaccb17849ee09.tar.bz2
ayatana-indicator-session-ce534e84c417692ee1a6a014defaccb17849ee09.zip
Merge branch 'tari01-pr/no-pie-only-in-tests'
Attributes GH PR #48: https://github.com/AyatanaIndicators/ayatana-indicator-session/pull/48
Diffstat (limited to 'tests/backend-dbus/CMakeLists.txt')
-rw-r--r--tests/backend-dbus/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/backend-dbus/CMakeLists.txt b/tests/backend-dbus/CMakeLists.txt
index 0589487..93ffc45 100644
--- a/tests/backend-dbus/CMakeLists.txt
+++ b/tests/backend-dbus/CMakeLists.txt
@@ -35,17 +35,20 @@ include_directories (${CMAKE_SOURCE_DIR}/tests)
# test the Actions class
add_executable (test-actions
test-actions.cc)
+target_link_options(test-actions PRIVATE -no-pie)
add_test (test-actions test-actions)
target_link_libraries (test-actions desktopmock backenddbus libayatanaindicatorsessionservice ${SERVICE_LDFLAGS} ${GTEST_LIBRARIES} ${GTEST_BOTH_LIBRARIES} ${GMOCK_LIBRARIES})
# test the Guest class
add_executable (test-guest
test-guest.cc)
+target_link_options(test-guest PRIVATE -no-pie)
add_test (test-guest test-guest)
target_link_libraries (test-guest desktopmock backenddbus libayatanaindicatorsessionservice ${SERVICE_LDFLAGS} ${GTEST_LIBRARIES} ${GTEST_BOTH_LIBRARIES} ${GMOCK_LIBRARIES})
# test the Users class
add_executable (test-users
test-users.cc)
+target_link_options(test-users PRIVATE -no-pie)
add_test (test-users test-users)
target_link_libraries (test-users desktopmock backenddbus libayatanaindicatorsessionservice ${SERVICE_LDFLAGS} ${GTEST_LIBRARIES} ${GTEST_BOTH_LIBRARIES} ${GMOCK_LIBRARIES})