aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 18 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ab12f12..a6a7b05 100644
--- a/configure.ac
+++ b/configure.ac
@@ -198,6 +198,18 @@ AC_DEFINE_PATH(GNOMELOCALEDIR, "${datadir}/locale", [locale directory])
AM_GLIB_GNU_GETTEXT
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AM_CONDITIONAL([HAVE_GCOV], [test "x$ac_cv_check_gcov" = xyes])
+AM_CONDITIONAL([HAVE_LCOV], [test "x$ac_cv_check_lcov" = xyes])
+AM_CONDITIONAL([HAVE_GCOVR], [test "x$ac_cv_check_gcovr" = xyes])
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Files
###########################
@@ -237,9 +249,10 @@ AC_MSG_NOTICE([
SUS Indicator Configuration:
- Prefix: $prefix
- Indicator Dir: $INDICATORDIR
- Indicator GTK: $with_gtk
- Logout Helper: $have_gtklogouthelper
- APT support: $enable_apt
+ Prefix: $prefix
+ Indicator Dir: $INDICATORDIR
+ Indicator GTK: $with_gtk
+ Logout Helper: $have_gtklogouthelper
+ APT support: $enable_apt
+ Coverage reporting: $use_gcov
])