aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-08-12 07:45:26 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-08-12 07:45:29 +0200
commit89b71ec63252f3c612155fceb9e90f2aeb8bce9e (patch)
tree71b3944b63df1b76bf5b1bba06be626638d8caf9 /CMakeLists.txt
parent85c01f5cfdf9f4bfa57db5904f88bc284bf0465f (diff)
downloadayatana-indicator-sound-89b71ec63252f3c612155fceb9e90f2aeb8bce9e.tar.gz
ayatana-indicator-sound-89b71ec63252f3c612155fceb9e90f2aeb8bce9e.tar.bz2
ayatana-indicator-sound-89b71ec63252f3c612155fceb9e90f2aeb8bce9e.zip
CMakeLists.txt: Drop workaround for missing libexec dir on Debian. Debian moved forward and now supports FHS 3.0 (since Debian Policy 4.1.5).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5bbd6f4..02c6a75 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,12 +10,6 @@ include(UseVala)
option (enable_tests "Build the package's automatic tests." ON)
-# Workaround for libexecdir on debian
-if (EXISTS "/etc/debian_version")
- set(CMAKE_INSTALL_LIBEXECDIR "${CMAKE_INSTALL_LIBDIR}")
- set(CMAKE_INSTALL_FULL_LIBEXECDIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBEXECDIR}")
-endif()
-
set(GETTEXT_PACKAGE "ayatana-indicator-sound")
set(LOCALEDIR "${CMAKE_INSTALL_FULL_DATADIR}/locale")
add_definitions( -DGETTEXT_PACKAGE="${GETTEXT_PACKAGE}" )