aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2022-02-17 23:24:26 +0100
committerRobert Tari <robert@tari.in>2022-02-17 23:43:05 +0100
commit901192f9fd427f19d5fe02a48d22fd306d62ab07 (patch)
tree9d6eaaf21a32a77f50351dec36521326446e2ec1 /CMakeLists.txt
parentbe9c06cecaa710f53a538b8975de72332904c1ca (diff)
downloadayatana-indicator-sound-901192f9fd427f19d5fe02a48d22fd306d62ab07.tar.gz
ayatana-indicator-sound-901192f9fd427f19d5fe02a48d22fd306d62ab07.tar.bz2
ayatana-indicator-sound-901192f9fd427f19d5fe02a48d22fd306d62ab07.zip
Clean up compilation flags
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4618aa..9c3dfa4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,8 +27,13 @@ else()
endif()
if(ENABLE_WERROR)
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+ add_definitions("-Werror")
+endif()
+
+if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+ add_definitions("-Weverything")
+else()
+ add_definitions("-Wall")
endif()
set(GETTEXT_PACKAGE "ayatana-indicator-sound")
@@ -82,13 +87,6 @@ find_package(GObjectIntrospection 0.9.12)
include_directories(${SOURCE_DIR})
include_directories(${SOURCE_BINARY_DIR})
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c11")
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
-
-add_definitions(
- -Wall
-)
-
configure_file(
"config.h.in"
"${CMAKE_CURRENT_BINARY_DIR}/config.h"