aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorConor Curran <conor.curran@canonical.com>2012-01-13 13:43:00 +0000
committerConor Curran <conor.curran@canonical.com>2012-01-13 13:43:00 +0000
commit9be5ce8beb52b3e4b1fa820dfaca5dea8f2db80e (patch)
tree0c1d23fa58f5463b7afddf46dceccb4df1bd801b /configure.ac
parente090ca7ce8c5d46962e9085ed96c55baa23cae65 (diff)
parent94f68e08df92dd859889d08706fe1f024f4962e8 (diff)
downloadayatana-indicator-sound-9be5ce8beb52b3e4b1fa820dfaca5dea8f2db80e.tar.gz
ayatana-indicator-sound-9be5ce8beb52b3e4b1fa820dfaca5dea8f2db80e.tar.bz2
ayatana-indicator-sound-9be5ce8beb52b3e4b1fa820dfaca5dea8f2db80e.zip
add Allans initial tdd work
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0e88562..22fffa1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,16 @@ AC_SUBST(SOUNDSERVICE_CFLAGS)
AC_SUBST(SOUNDSERVICE_LIBS)
###########################
+# gcov coverage reporting
+###########################
+
+m4_include([m4/gcov.m4])
+AC_TDD_GCOV
+AC_SUBST(COVERAGE_CFLAGS)
+AC_SUBST(COVERAGE_CXXFLAGS)
+AC_SUBST(COVERAGE_LDFLAGS)
+
+###########################
# Check to see if we're local
###########################
@@ -188,4 +198,5 @@ SUS Indicator Configuration:
Prefix: $prefix
GTK+: $with_gtk
+ gcov: $use_gcov
])