aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-02-20 10:29:58 -0600
committerTed Gould <ted@gould.cx>2014-02-20 10:29:58 -0600
commit363d3454908ca4081ff778e1cabfd38d68bc31ec (patch)
tree9b93cababa3e3eda4ab401d72120bbdd424b3df8 /data/CMakeLists.txt
parent1900dc381fecd415390471971ef4b433dbc6dc31 (diff)
downloadayatana-indicator-sound-363d3454908ca4081ff778e1cabfd38d68bc31ec.tar.gz
ayatana-indicator-sound-363d3454908ca4081ff778e1cabfd38d68bc31ec.tar.bz2
ayatana-indicator-sound-363d3454908ca4081ff778e1cabfd38d68bc31ec.zip
Add in the Upstart override
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 565e652..80046f7 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -57,6 +57,27 @@ install(
)
###########################
+# Upstart XDG Autostart Override
+###########################
+
+set(
+ INDICATOR_SOUND_UPSTART_XDG_AUTOSTART
+ "${CMAKE_CURRENT_BINARY_DIR}/indicator-sound.upstart.desktop"
+)
+
+configure_file(
+ "indicator-sound.upstart.desktop.in"
+ ${INDICATOR_SOUND_UPSTART_XDG_AUTOSTART}
+ @ONLY
+)
+
+install(
+ FILES "${INDICATOR_SOUND_UPSTART_XDG_AUTOSTART}"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/upstart/xdg/autostart"
+ RENAME "indicator-sound.desktop"
+)
+
+###########################
# GSettings
###########################