aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2013-08-27 10:58:07 -0500
committerTed Gould <ted@gould.cx>2013-08-27 10:58:07 -0500
commit3f3f5915a4ade92a74633e1b4d7dc19822223213 (patch)
tree73430e480c436187ea247b2830f3c5c9cb1f6fea /data/CMakeLists.txt
parentf21921053ac8cf50438ff418539cf22d9a86c8bb (diff)
parentdc721ac25d910a08fc3806330b2f8bd8d3b2a4dd (diff)
downloadayatana-indicator-sound-3f3f5915a4ade92a74633e1b4d7dc19822223213.tar.gz
ayatana-indicator-sound-3f3f5915a4ade92a74633e1b4d7dc19822223213.tar.bz2
ayatana-indicator-sound-3f3f5915a4ade92a74633e1b4d7dc19822223213.zip
Merge Trunk
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
new file mode 100644
index 0000000..e71051e
--- /dev/null
+++ b/data/CMakeLists.txt
@@ -0,0 +1,43 @@
+
+include(UseGSettings)
+
+###########################
+# Indicator service
+###########################
+
+set(
+ INDICATOR_DIR
+ "${CMAKE_INSTALL_DATADIR}/unity/indicators"
+ CACHE FILEPATH "Indicator directory"
+)
+
+install(
+ FILES "com.canonical.indicator.sound"
+ DESTINATION "${INDICATOR_DIR}"
+)
+
+###########################
+# Dbus Service
+###########################
+
+set(
+ INDICATOR_SOUND_CONF
+ "${CMAKE_CURRENT_BINARY_DIR}/indicator-sound.conf"
+)
+
+configure_file(
+ "indicator-sound.conf.in"
+ ${INDICATOR_SOUND_CONF}
+ @ONLY
+)
+
+install(
+ FILES "${INDICATOR_SOUND_CONF}"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/upstart/sessions/"
+)
+
+###########################
+# GSettings
+###########################
+
+add_schema ("com.canonical.indicator.sound.gschema.xml")