aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-11-10 11:19:39 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-11-12 13:13:10 +0100
commit611fb696d239afec803bd2fdfdcbc1b475ff3a26 (patch)
treef7131a27f3a989d1294740466fed4f33af84cd6e /data/CMakeLists.txt
parent27963fd99ac38eee2477ec6ae6e8d2882959994a (diff)
downloadayatana-indicator-sound-611fb696d239afec803bd2fdfdcbc1b475ff3a26.tar.gz
ayatana-indicator-sound-611fb696d239afec803bd2fdfdcbc1b475ff3a26.tar.bz2
ayatana-indicator-sound-611fb696d239afec803bd2fdfdcbc1b475ff3a26.zip
Drop org.ayatana.AccountsService.Sound
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt30
1 files changed, 0 insertions, 30 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index f2873d9..ee9d97f 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -93,33 +93,3 @@ DESTINATION "${POLKIT_DATA_DIR}/actions"
install(FILES 50-org.ayatana.indicator.sound.AccountsService.pkla
DESTINATION "${POLKIT_LIB_DIR}/localauthority/10-vendor.d"
)
-
-#######################################
-# Accounts Service Iface: Greeter Sound
-#######################################
-
-if(EXISTS "/usr/share/accountsservice/interfaces/com.lomiri.AccountsService.Sound.xml")
-
- # Nothing to do here...
- # Using files from Lomiri specific package 'lomiri-schemas'.
-
-else()
-
- install(FILES org.ayatana.AccountsService.Sound.xml
- DESTINATION "${DBUS_IFACE_DIR}"
- )
-
- # Create accountsservice symlink for above dbus interface
- install(CODE "
- execute_process(COMMAND mkdir -p \"\$ENV{DESTDIR}${ACCOUNTS_IFACE_DIR}\")
- execute_process(COMMAND ln -sf ../../dbus-1/interfaces/org.ayatana.AccountsService.Sound.xml \"\$ENV{DESTDIR}${ACCOUNTS_IFACE_DIR}\")
- ")
-
- install(FILES org.ayatana.AccountsService.Sound.policy
- DESTINATION "${POLKIT_DATA_DIR}/actions"
- )
-
- install(FILES 50-org.ayatana.AccountsService.Sound.pkla
- DESTINATION "${POLKIT_LIB_DIR}/localauthority/10-vendor.d"
- )
-endif()