aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2013-10-28 17:52:03 -0700
committerTed Gould <ted@gould.cx>2013-10-28 17:52:03 -0700
commit6a2a81ed1b6f4ef820f96b3249dc062e68e480f9 (patch)
treefea9c770c811b5b7819ca117b46fa63ae9521872 /data/CMakeLists.txt
parent4f6b673281fecd22c618c700af0bd798ee5c26f1 (diff)
downloadayatana-indicator-sound-6a2a81ed1b6f4ef820f96b3249dc062e68e480f9.tar.gz
ayatana-indicator-sound-6a2a81ed1b6f4ef820f96b3249dc062e68e480f9.tar.bz2
ayatana-indicator-sound-6a2a81ed1b6f4ef820f96b3249dc062e68e480f9.zip
Adding an XDG Autostart file
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt22
1 files changed, 21 insertions, 1 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index e71051e..ec27376 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -17,7 +17,7 @@ install(
)
###########################
-# Dbus Service
+# Upstart Job
###########################
set(
@@ -37,6 +37,26 @@ install(
)
###########################
+# XDG Autostart
+###########################
+
+set(
+ INDICATOR_SOUND_XDG_AUTOSTART
+ "${CMAKE_CURRENT_BINARY_DIR}/indicator-sound.desktop"
+)
+
+configure_file(
+ "indicator-sound.desktop.in"
+ ${INDICATOR_SOUND_CONF}
+ @ONLY
+)
+
+install(
+ FILES "${INDICATOR_SOUND_XDG_AUTOSTART}"
+ DESTINATION "/etc/xdg/autostart"
+)
+
+###########################
# GSettings
###########################