aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorPete Woods <pete.woods@canonical.com>2013-08-16 04:13:41 +0100
committerPete Woods <pete.woods@canonical.com>2013-08-16 04:13:41 +0100
commit796a887cf88c1ad23ab06e89435ca1e04080aaee (patch)
treee449f277b6672abd016afd97ff1210e32948b46d /data/CMakeLists.txt
parent4fedffcef1054e4093c4528d40cce809f1e958b3 (diff)
downloadayatana-indicator-sound-796a887cf88c1ad23ab06e89435ca1e04080aaee.tar.gz
ayatana-indicator-sound-796a887cf88c1ad23ab06e89435ca1e04080aaee.tar.bz2
ayatana-indicator-sound-796a887cf88c1ad23ab06e89435ca1e04080aaee.zip
Build using cmake
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
new file mode 100644
index 0000000..c66ca69
--- /dev/null
+++ b/data/CMakeLists.txt
@@ -0,0 +1,43 @@
+
+include(UseGSettings)
+
+###########################
+# Indicator service
+###########################
+
+set(
+ INDICATOR_DIR
+ "${CMAKE_INSTALL_DATADIR}/unity/indicators"
+ CACHE FILEPATH "Indicator directory"
+)
+
+install(
+ FILES "com.canonical.indicator.sound"
+ DESTINATION "${INDICATOR_DIR}"
+)
+
+###########################
+# Dbus Service
+###########################
+
+set(
+ INDICATOR_SOUND_SERVICE
+ "${CMAKE_CURRENT_BINARY_DIR}/indicator-sound.service"
+)
+
+configure_file(
+ "indicator-sound.service.in"
+ ${INDICATOR_SOUND_SERVICE}
+ @ONLY
+)
+
+install(
+ FILES "${INDICATOR_SOUND_SERVICE}"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/dbus-1/services/"
+)
+
+###########################
+# GSettings
+###########################
+
+add_schema ("com.canonical.indicator.sound.gschema.xml")