aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-03-24 15:02:25 +0000
committerCI bot <ps-jenkins@lists.canonical.com>2014-03-24 15:02:25 +0000
commit7a312f2f03a0bc0c52ce8a6f834849d70233cf61 (patch)
treeb7e124f7b3297dc0ea03e08052ae63a7d0d0acc6 /data/CMakeLists.txt
parent0aae819193bfd6dba02207c4513ccb038d412d4e (diff)
parent7d47058ef00b8aab6e7b58e20bd6e5fbcecdfc34 (diff)
downloadayatana-indicator-sound-7a312f2f03a0bc0c52ce8a6f834849d70233cf61.tar.gz
ayatana-indicator-sound-7a312f2f03a0bc0c52ce8a6f834849d70233cf61.tar.bz2
ayatana-indicator-sound-7a312f2f03a0bc0c52ce8a6f834849d70233cf61.zip
Export currently running player to Accounts Service
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 80046f7..955a4a4 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -82,3 +82,35 @@ install(
###########################
add_schema ("com.canonical.indicator.sound.gschema.xml")
+
+###########################
+# Accounts Service
+###########################
+
+
+set(POLKIT_LIB_DIR "${CMAKE_INSTALL_LOCALSTATEDIR}/lib/polkit-1")
+set(POLKIT_DATA_DIR "${CMAKE_INSTALL_PREFIX}/share/polkit-1")
+set(DBUS_IFACE_DIR "${CMAKE_INSTALL_PREFIX}/share/dbus-1/interfaces")
+set(ACCOUNTS_IFACE_DIR "${CMAKE_INSTALL_PREFIX}/share/accountsservice/interfaces")
+
+install(FILES com.canonical.indicator.sound.AccountsService.xml
+ DESTINATION "${DBUS_IFACE_DIR}"
+)
+
+# Create accountsservice symlink for above dbus interface
+install(CODE "
+ execute_process(COMMAND mkdir -p \"\$ENV{DESTDIR}${ACCOUNTS_IFACE_DIR}\")
+ execute_process(COMMAND ln -sf ../../dbus-1/interfaces/com.canonical.indicator.sound.AccountsService.xml \"\$ENV{DESTDIR}${ACCOUNTS_IFACE_DIR}\")
+")
+
+install(FILES com.canonical.indicator.sound.AccountsService.policy
+DESTINATION "${POLKIT_DATA_DIR}/actions"
+)
+
+install(FILES 50-com.canonical.indicator.sound.AccountsService.pkla
+DESTINATION "${POLKIT_LIB_DIR}/localauthority/10-vendor.d"
+)
+
+
+
+