aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-02-10 11:54:07 -0600
committerTed Gould <ted@gould.cx>2014-02-10 11:54:07 -0600
commit9660d0b5c1cee59d7b34e989fc2da19b67167619 (patch)
tree2b4f4e3b40ef6bd05f1c2734d8218b46ab679229 /data/CMakeLists.txt
parent1711049123981c79400b06ccd46d4e010925e33b (diff)
downloadayatana-indicator-sound-9660d0b5c1cee59d7b34e989fc2da19b67167619.tar.gz
ayatana-indicator-sound-9660d0b5c1cee59d7b34e989fc2da19b67167619.tar.bz2
ayatana-indicator-sound-9660d0b5c1cee59d7b34e989fc2da19b67167619.zip
Trying to put together all our account service pieces
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 565e652..9694a9e 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -61,3 +61,35 @@ install(
###########################
add_schema ("com.canonical.indicator.sound.gschema.xml")
+
+###########################
+# Accounts Service
+###########################
+
+
+set(POLKIT_LIB_DIR "${CMAKE_INSTALL_LOCALSTATEDIR}/lib/polkit-1")
+set(POLKIT_DATA_DIR "${CMAKE_INSTALL_PREFIX}/share/polkit-1")
+set(DBUS_IFACE_DIR "${CMAKE_INSTALL_PREFIX}/share/dbus-1/interfaces")
+set(ACCOUNTS_IFACE_DIR "${CMAKE_INSTALL_PREFIX}/share/accountsservice/interfaces")
+
+install(FILES com.canonical.indicator.sound.AccountsService.xml
+ DESTINATION "${DBUS_IFACE_DIR}"
+)
+
+# Create accountsservice symlink for above dbus interface
+install(CODE "
+ execute_process(COMMAND mkdir -p \"\$ENV{DESTDIR}${ACCOUNTS_IFACE_DIR}\")
+ execute_process(COMMAND ln -sf ../../dbus-1/interfaces/com.canonical.indicator.sound.AccountsService.xml \"\$ENV{DESTDIR}${ACCOUNTS_IFACE_DIR}\")
+")
+
+install(FILES com.canonical.indicator.sound.AccountsService.policy
+DESTINATION "${POLKIT_DATA_DIR}/actions"
+)
+
+install(FILES 50-com.canonical.indicator.sound.AccountsService.pkla
+DESTINATION "${POLKIT_LIB_DIR}/localauthority/10-vendor.d"
+)
+
+
+
+